Jovian
⭐️
Sign In
In [5]:
!pip install git+https://github.com/Jie-Yuan/X-plan.git -U -i https://pypi.tuna.tsinghua.edu.cn/simple
Looking in indexes: https://pypi.tuna.tsinghua.edu.cn/simple Collecting git+https://github.com/Jie-Yuan/X-plan.git Cloning https://github.com/Jie-Yuan/X-plan.git to /tmp/pip-req-build-uhb7upba Requirement already satisfied, skipping upgrade: sanic in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (18.12.0) Requirement already satisfied, skipping upgrade: tqdm in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (4.31.1) Requirement already satisfied, skipping upgrade: wrapt in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (1.11.1) Requirement already satisfied, skipping upgrade: jieba in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.39) Requirement already satisfied, skipping upgrade: keras in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (2.2.4) Requirement already satisfied, skipping upgrade: lightgbm in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (2.2.4) Requirement already satisfied, skipping upgrade: catboost in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.12.2) Requirement already satisfied, skipping upgrade: rgf_python in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (3.5.0) Requirement already satisfied, skipping upgrade: bayesian-optimization in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (1.0.1) Requirement already satisfied, skipping upgrade: statsmodels in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.9.0) Requirement already satisfied, skipping upgrade: tables in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (3.4.4) Requirement already satisfied, skipping upgrade: eli5 in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.8.1) Requirement already satisfied, skipping upgrade: shap in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.28.5) Requirement already satisfied, skipping upgrade: seaborn in /usr/local/lib/python3.5/dist-packages (from x-plan==0.0.1) (0.9.0) Requirement already satisfied, skipping upgrade: aiofiles>=0.3.0 in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (0.4.0) Requirement already satisfied, skipping upgrade: websockets<7.0,>=6.0 in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (6.0) Requirement already satisfied, skipping upgrade: ujson>=1.35; sys_platform != "win32" and implementation_name == "cpython" in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (1.35) Requirement already satisfied, skipping upgrade: uvloop>=0.5.3; sys_platform != "win32" and implementation_name == "cpython" in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (0.12.1) Requirement already satisfied, skipping upgrade: httptools>=0.0.10 in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (0.0.13) Requirement already satisfied, skipping upgrade: multidict<5.0,>=4.0 in /usr/local/lib/python3.5/dist-packages (from sanic->x-plan==0.0.1) (4.5.2) Requirement already satisfied, skipping upgrade: h5py in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (2.9.0) Requirement already satisfied, skipping upgrade: scipy>=0.14 in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (1.1.0) Requirement already satisfied, skipping upgrade: keras-applications>=1.0.6 in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (1.0.6) Requirement already satisfied, skipping upgrade: six>=1.9.0 in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (1.11.0) Requirement already satisfied, skipping upgrade: pyyaml in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (3.13) Requirement already satisfied, skipping upgrade: numpy>=1.9.1 in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (1.15.4) Requirement already satisfied, skipping upgrade: keras-preprocessing>=1.0.5 in /usr/local/lib/python3.5/dist-packages (from keras->x-plan==0.0.1) (1.0.5) Requirement already satisfied, skipping upgrade: scikit-learn in /usr/local/lib/python3.5/dist-packages (from lightgbm->x-plan==0.0.1) (0.20.0) Requirement already satisfied, skipping upgrade: enum34 in /usr/local/lib/python3.5/dist-packages (from catboost->x-plan==0.0.1) (1.1.6) Requirement already satisfied, skipping upgrade: pandas>=0.19.1 in /usr/local/lib/python3.5/dist-packages (from catboost->x-plan==0.0.1) (0.23.4) Requirement already satisfied, skipping upgrade: patsy in /usr/local/lib/python3.5/dist-packages (from statsmodels->x-plan==0.0.1) (0.5.1) Requirement already satisfied, skipping upgrade: numexpr>=2.5.2 in /usr/local/lib/python3.5/dist-packages (from tables->x-plan==0.0.1) (2.6.9) Requirement already satisfied, skipping upgrade: typing in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (3.6.6) Requirement already satisfied, skipping upgrade: graphviz in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (0.10.1) Requirement already satisfied, skipping upgrade: attrs>16.0.0 in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (19.1.0) Requirement already satisfied, skipping upgrade: singledispatch>=3.4.0.3; python_version < "3.5.6" in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (3.4.0.3) Requirement already satisfied, skipping upgrade: jinja2 in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (2.10) Requirement already satisfied, skipping upgrade: tabulate>=0.7.7 in /usr/local/lib/python3.5/dist-packages (from eli5->x-plan==0.0.1) (0.8.3) Requirement already satisfied, skipping upgrade: matplotlib in /usr/local/lib/python3.5/dist-packages (from shap->x-plan==0.0.1) (3.0.2) Requirement already satisfied, skipping upgrade: ipython in /usr/local/lib/python3.5/dist-packages (from shap->x-plan==0.0.1) (7.1.1) Requirement already satisfied, skipping upgrade: scikit-image in /usr/local/lib/python3.5/dist-packages (from shap->x-plan==0.0.1) (0.14.1) Requirement already satisfied, skipping upgrade: python-dateutil>=2.5.0 in /usr/local/lib/python3.5/dist-packages (from pandas>=0.19.1->catboost->x-plan==0.0.1) (2.7.5) Requirement already satisfied, skipping upgrade: pytz>=2011k in /usr/local/lib/python3.5/dist-packages (from pandas>=0.19.1->catboost->x-plan==0.0.1) (2018.7) Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in /usr/local/lib/python3.5/dist-packages (from jinja2->eli5->x-plan==0.0.1) (1.1.0) Requirement already satisfied, skipping upgrade: kiwisolver>=1.0.1 in /usr/local/lib/python3.5/dist-packages (from matplotlib->shap->x-plan==0.0.1) (1.0.1) Requirement already satisfied, skipping upgrade: cycler>=0.10 in /usr/local/lib/python3.5/dist-packages (from matplotlib->shap->x-plan==0.0.1) (0.10.0) Requirement already satisfied, skipping upgrade: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in /usr/local/lib/python3.5/dist-packages (from matplotlib->shap->x-plan==0.0.1) (2.3.0) Requirement already satisfied, skipping upgrade: setuptools>=18.5 in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (40.8.0) Requirement already satisfied, skipping upgrade: prompt-toolkit<2.1.0,>=2.0.0 in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (2.0.7) Requirement already satisfied, skipping upgrade: traitlets>=4.2 in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (4.3.2) Requirement already satisfied, skipping upgrade: pygments in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (2.2.0) Requirement already satisfied, skipping upgrade: backcall in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (0.1.0) Requirement already satisfied, skipping upgrade: jedi>=0.10 in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (0.13.1) Requirement already satisfied, skipping upgrade: pickleshare in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (0.7.5) Requirement already satisfied, skipping upgrade: pexpect; sys_platform != "win32" in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (4.6.0) Requirement already satisfied, skipping upgrade: decorator in /usr/local/lib/python3.5/dist-packages (from ipython->shap->x-plan==0.0.1) (4.3.0) Requirement already satisfied, skipping upgrade: networkx>=1.8 in /usr/local/lib/python3.5/dist-packages (from scikit-image->shap->x-plan==0.0.1) (2.2)
Requirement already satisfied, skipping upgrade: PyWavelets>=0.4.0 in /usr/local/lib/python3.5/dist-packages (from scikit-image->shap->x-plan==0.0.1) (1.0.1) Requirement already satisfied, skipping upgrade: dask[array]>=0.9.0 in /usr/local/lib/python3.5/dist-packages (from scikit-image->shap->x-plan==0.0.1) (1.0.0) Requirement already satisfied, skipping upgrade: cloudpickle>=0.2.1 in /usr/local/lib/python3.5/dist-packages (from scikit-image->shap->x-plan==0.0.1) (0.6.1) Requirement already satisfied, skipping upgrade: pillow>=4.3.0 in /usr/local/lib/python3.5/dist-packages (from scikit-image->shap->x-plan==0.0.1) (5.3.0) Requirement already satisfied, skipping upgrade: wcwidth in /usr/local/lib/python3.5/dist-packages (from prompt-toolkit<2.1.0,>=2.0.0->ipython->shap->x-plan==0.0.1) (0.1.7) Requirement already satisfied, skipping upgrade: ipython-genutils in /usr/local/lib/python3.5/dist-packages (from traitlets>=4.2->ipython->shap->x-plan==0.0.1) (0.2.0) Requirement already satisfied, skipping upgrade: parso>=0.3.0 in /usr/local/lib/python3.5/dist-packages (from jedi>=0.10->ipython->shap->x-plan==0.0.1) (0.3.1) Requirement already satisfied, skipping upgrade: ptyprocess>=0.5 in /usr/local/lib/python3.5/dist-packages (from pexpect; sys_platform != "win32"->ipython->shap->x-plan==0.0.1) (0.6.0) Requirement already satisfied, skipping upgrade: toolz>=0.7.3; extra == "array" in /usr/local/lib/python3.5/dist-packages (from dask[array]>=0.9.0->scikit-image->shap->x-plan==0.0.1) (0.9.0) Building wheels for collected packages: x-plan Building wheel for x-plan (setup.py) ... done Stored in directory: /tmp/pip-ephem-wheel-cache-33s0dvy_/wheels/8d/ad/0d/66da64c133ce5f9dcc0b8910d3ccf2aa7833dc95fcde0e5402 Successfully built x-plan Installing collected packages: x-plan Found existing installation: x-plan 0.0.1 Uninstalling x-plan-0.0.1: Successfully uninstalled x-plan-0.0.1 Successfully installed x-plan-0.0.1
In [1]:
import jovian
In [ ]:
jovian.commit()
[jovian] Saving notebook..
In [5]:
!which python
/usr/bin/python
In [7]:
!python
Python 3.5.2 (default, Nov 23 2017, 16:37:01) [GCC 5.4.0 20160609] on linux Type "help", "copyright", "credits" or "license" for more information. >>> Traceback (most recent call last): File "<stdin>", line 1, in <module> KeyboardInterrupt >>>
In [ ]: