I can't save my work from colab to jovian

when I try to commit any project to jovian, it shows the following error :

[jovian] Detected Colab notebook...

[jovian] Please enter your API key ( from https://jovian.ai/ ):
API KEY: ··········
[jovian] Uploading colab notebook to Jovian…

ApiError Traceback (most recent call last)
in ()
----> 1 jovian.commit(project=‘01-tensor-operations’)

1 frames
/usr/local/lib/python3.6/dist-packages/jovian/utils/colab.py in perform_colab_commit(project, privacy)
45 if res.status_code == 200:
46 return res.json()[‘data’]
—> 47 raise ApiError('Colab commit failed: ’ + pretty(res))

ApiError: Colab commit failed: (HTTP 400) Unauthorized access to sadiqbasit782/01-tensor-operations

This is what I experience too, I wish we could have timely solution to that.

Hey @gbadamus @abdulbee sorry for the late reply. Can you guys please verify if the API key and the project is from the same account? This is a possible scenario, let me know about this. I’ll also investigate if there is any possible bug.

Yes, my project is from my account, Though I was able to save my project on jovian with binder. But, colab failed me .

1 Like

Yes, they’re from the same account

However, this problem is only with google colab. When I tried running the notebooks from my local computer, the commit worked fine. it worked fine with paperspace too.

So, I’ve been using paperspace, and everything works fine.

I think in the mean time, you should run the notebooks on your local computer, or get a free notebook on paperspace.

That way, you’ll be able to meet deadlines for the assignments