Lecture 1 - PyTorch Basics & Linear Regression

Livestream Link: https://www.youtube.com/watch?v=vo_fUOk-IKk

Lecture Timing: May 23 (Sat), 8.30 AM PST/9:00 PM IST (2 hours)


  1. PyTorch Basics: https://jovian.ai/aakashns/01-pytorch-basics
  2. Linear Regression: https://jovian.ai/aakashns/02-linear-regression
  3. Machine Learning Intro: https://jovian.ai/aakashns/machine-learning-intro

Update: We have dropped the attendance requirement. No need to mark it.

  • I’m watching the lecture

0 voters

What to do after the lecture?

Asking/Answering Questions:
Reply on this thread to ask questions during and after the lecture. Before asking, scroll through the thread and check if your question (or a similar one) is already present. If yes, just like it. During the lecture, we’ll answer 8-10 questions with the most likes. The rest will be answered on the forum. If you see a question you know the answer to, please post your answer as a reply to that question. Let’s help each other learn!


A post was merged into an existing topic: Introduce Yourself Here

What must we do after this lecture ? Exercice ?


A post was merged into an existing topic: Introduce Yourself Here

Hello there,just want to ask i ty install the jovian after i follow the step but after i successfully run jupyter but when i run the code the error pop out say python.exe -Ordinal Not found. Anyone had the same problem!


Will the youtube lecture be available later for viewing it again, after the live session ?


Yes it’ll be available @SShankar

1 Like

This is a weird issue let me check it. Can you mention when you do get it error while running a jupyter cell ? @edsenmichaelcy

@lucascolas It will be mentioned during the stream.

Please a premiere notification for the session has just popped on freecodecamp. Is this the lecture 1? Also someone there said we should go mark register on the forum, which attendance is that and how do we mark it?


Ok. Thank you for your answer !

1 Like

Yes it is lecture 1 today in about 23 minutes. Please refer the description of this thread for the attendance poll.Lecture 1 - PyTorch Basics & Linear Regression


I have the same problem… and I did uncomment the line !conda install pytorch cpuonly -c pytorch -y . If anybody has any ideas i wopuld love them… other wise I will setup a Debian enviroment.

Hello there @ PrajwalPrashanth sorry to reply late.
I get this error message when I run the code import torch and the rest of the code. But normal python is able to work

I already marked the attendance will it be okay

1 Like

I get the error when I am trying to import torch. and I already uncommented the line and it says

Collecting package metadata (current_repodata.json): …working… done
Solving environment: …working… done

All requested packages already installed.

Then when I try to run the next cell:

import torch

I get





A humble request do show the steps to install and how to go forward with Jovian into our notebooks.
It will be helpful - thank you!


I also got the same error…now I am using my base conda enviroment…in that I am not getting any error

1 Like

@PrajwalPrashanth when I try to install the pip jovian it came out an error is “Some pip package fail to install” as the picture below… Is this causing the problem I mention above