Problems using notebook

when I fork a topic from python: zero to gans course, it doesn’t work perfectly next time I run from my profile. for instance, jupyter notebook was not able to install the PyTorch properly, thus not a single command was running in my notebook. now as I see, my codes are showing that it’s running but it doesn’t generate any output. how to solve this?

  1. Did you run the notebook “from scratch”?
  2. Are you running locally or binder/kaggle/colab?

I have a feeling that the images may show up in different directory. The network is actually running, but the images are stored as PNG/JPEG files somewhere else.

well, it happens both the times. Like, if i start from scratch or when i open zero to gans notebook from akash’s profile and commit it and opening it from my profile. I use binder in this case.

So what exactly happens when you open Binder and you execute all cells from top?

BTW. use the “Reply” button, it might help with getting the response quicker (I have notifications enabled, some ppl have them too prolly).

when i try to run in binder, in some of the cases its showing like this and in some other cases, the dependencies are not being installed correctly.

It seems like it’s stuck installing pytorch.

I don’t use conda that much so no idea what’s going behind. Since it’s binder I’m suspecting the connection is available.

Maybe you’re still executing some cell? In binder there’s a “Restart kernel” option somewhere (top bar). If you don’t do “from scratch” by using this command, then your notebook is probably stuck executing some cell (and generating the images from generator).

I would try to replace the whole conda line with pip install torch -q if you’re really sure you aren’t executing some different cell.

still it doesnt help, making the same error again and again

Is your notebook public? I’m gonna try and run it myself to see what’s wrong.