Jovian
⭐️
Sign In
In [1]:
!pip install jovian --upgrade
!pip install pmdarima
Collecting jovian Downloading https://files.pythonhosted.org/packages/b8/a1/dd7b5bcf0a3f043c894151f5e523c1f88ab72ed5672694f325e2f39e85f1/jovian-0.1.97-py2.py3-none-any.whl (50kB) |████████████████████████████████| 51kB 2.5MB/s eta 0:00:011 Requirement already satisfied, skipping upgrade: pyyaml in /srv/conda/envs/notebook/lib/python3.7/site-packages (from jovian) (5.1.2) Requirement already satisfied, skipping upgrade: uuid in /srv/conda/envs/notebook/lib/python3.7/site-packages (from jovian) (1.30) Collecting click (from jovian) Downloading https://files.pythonhosted.org/packages/fa/37/45185cb5abbc30d7257104c434fe0b07e5a195a6847506c074527aa599ec/Click-7.0-py2.py3-none-any.whl (81kB) |████████████████████████████████| 81kB 7.3MB/s eta 0:00:011 Requirement already satisfied, skipping upgrade: requests in /srv/conda/envs/notebook/lib/python3.7/site-packages (from jovian) (2.22.0) Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from requests->jovian) (2019.9.11) Requirement already satisfied, skipping upgrade: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from requests->jovian) (1.25.3) Requirement already satisfied, skipping upgrade: idna<2.9,>=2.5 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from requests->jovian) (2.8) Requirement already satisfied, skipping upgrade: chardet<3.1.0,>=3.0.2 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from requests->jovian) (3.0.4) Installing collected packages: click, jovian Found existing installation: jovian 0.1.89 Uninstalling jovian-0.1.89: Successfully uninstalled jovian-0.1.89 Successfully installed click-7.0 jovian-0.1.97 Collecting pmdarima Downloading https://files.pythonhosted.org/packages/1a/bd/fc357ead270a483fc1ecf8cf4da8f38bca767f14449a7821481a0bdd3366/pmdarima-1.5.2-cp37-cp37m-manylinux1_x86_64.whl (1.4MB) |████████████████████████████████| 1.5MB 3.5MB/s eta 0:00:01 |█████████████▉ | 624kB 3.5MB/s eta 0:00:01 Collecting scikit-learn>=0.19 (from pmdarima) Downloading https://files.pythonhosted.org/packages/73/db/7d8204ddba84ab5d1e4fd1af8f82bbe39c589488bee71e45c662f4144010/scikit_learn-0.22.1-cp37-cp37m-manylinux1_x86_64.whl (7.0MB) |████████████████████████████████| 7.0MB 14.2MB/s eta 0:00:01 |███████▉ | 1.7MB 14.2MB/s eta 0:00:01 Collecting statsmodels>=0.10.0 (from pmdarima) Downloading https://files.pythonhosted.org/packages/a6/32/5f8cff131e678a73b8f390ff7d8a04d502ed45e379378a0c5b9c25175239/statsmodels-0.10.2-cp37-cp37m-manylinux1_x86_64.whl (8.1MB) |████████████████████████████████| 8.1MB 56.3MB/s eta 0:00:01 Collecting Cython>=0.29 (from pmdarima) Downloading https://files.pythonhosted.org/packages/d8/58/2deb24de3c10cc4c0f09639b46f4f4b50059f0fdc785128a57dd9fdce026/Cython-0.29.14-cp37-cp37m-manylinux1_x86_64.whl (2.1MB) |████████████████████████████████| 2.1MB 50.6MB/s eta 0:00:01 Collecting numpy>=1.16 (from pmdarima) Downloading https://files.pythonhosted.org/packages/63/0c/0261693cc3ad8e2b66e66dc2d2676a2cc17d3efb1c58a70db73754320e47/numpy-1.18.1-cp37-cp37m-manylinux1_x86_64.whl (20.1MB) |████████████████████████████████| 20.1MB 55.1MB/s eta 0:00:01 Collecting joblib>=0.11 (from pmdarima) Downloading https://files.pythonhosted.org/packages/28/5c/cf6a2b65a321c4a209efcdf64c2689efae2cb62661f8f6f4bb28547cf1bf/joblib-0.14.1-py2.py3-none-any.whl (294kB) |████████████████████████████████| 296kB 54.5MB/s eta 0:00:01 Collecting scipy>=1.3 (from pmdarima) Downloading https://files.pythonhosted.org/packages/dd/82/c1fe128f3526b128cfd185580ba40d01371c5d299fcf7f77968e22dfcc2e/scipy-1.4.1-cp37-cp37m-manylinux1_x86_64.whl (26.1MB) |████████████████████████████████| 26.1MB 43.0MB/s eta 0:00:01 Collecting pandas>=0.19 (from pmdarima) Downloading https://files.pythonhosted.org/packages/63/e0/a1b39cdcb2c391f087a1538bc8a6d62a82d0439693192aef541d7b123769/pandas-0.25.3-cp37-cp37m-manylinux1_x86_64.whl (10.4MB) |████████████████████████████████| 10.4MB 37.2MB/s eta 0:00:01 |█████████████ | 4.2MB 37.2MB/s eta 0:00:01 Collecting patsy>=0.4.0 (from statsmodels>=0.10.0->pmdarima) Downloading https://files.pythonhosted.org/packages/ea/0c/5f61f1a3d4385d6bf83b83ea495068857ff8dfb89e74824c6e9eb63286d8/patsy-0.5.1-py2.py3-none-any.whl (231kB) |████████████████████████████████| 235kB 55.6MB/s eta 0:00:01 Collecting pytz>=2017.2 (from pandas>=0.19->pmdarima) Downloading https://files.pythonhosted.org/packages/e7/f9/f0b53f88060247251bf481fa6ea62cd0d25bf1b11a87888e53ce5b7c8ad2/pytz-2019.3-py2.py3-none-any.whl (509kB) |████████████████████████████████| 512kB 38.7MB/s eta 0:00:01 Requirement already satisfied: python-dateutil>=2.6.1 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from pandas>=0.19->pmdarima) (2.8.0) Requirement already satisfied: six in /srv/conda/envs/notebook/lib/python3.7/site-packages (from patsy>=0.4.0->statsmodels>=0.10.0->pmdarima) (1.12.0) Installing collected packages: numpy, joblib, scipy, scikit-learn, patsy, pytz, pandas, statsmodels, Cython, pmdarima Successfully installed Cython-0.29.14 joblib-0.14.1 numpy-1.18.1 pandas-0.25.3 patsy-0.5.1 pmdarima-1.5.2 pytz-2019.3 scikit-learn-0.22.1 scipy-1.4.1 statsmodels-0.10.2
In [2]:
import jovian
In [3]:
jovian.commit()
[jovian] Saving notebook..
[jovian] Git repository identified. Performing git commit... [jovian] Please enter your API key ( from https://jovian.ml/ ): API KEY: ········ [jovian] Creating a new notebook on https://jovian.ml/ [jovian] Uploading notebook.. [jovian] Capturing environment.. [jovian] Recording metrics, hyperparameters, datasets & git information.. [jovian] Committed successfully! https://jovian.ml/sai0684/time-series-tutorial-by-rohan-rao
In [9]:
!pip install lightgbm
!pip install pystan
!pip install fbprophet
Requirement already satisfied: lightgbm in /srv/conda/envs/notebook/lib/python3.7/site-packages (2.3.1) Requirement already satisfied: scipy in /srv/conda/envs/notebook/lib/python3.7/site-packages (from lightgbm) (1.4.1) Requirement already satisfied: scikit-learn in /srv/conda/envs/notebook/lib/python3.7/site-packages (from lightgbm) (0.22.1) Requirement already satisfied: numpy in /srv/conda/envs/notebook/lib/python3.7/site-packages (from lightgbm) (1.18.1) Requirement already satisfied: joblib>=0.11 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from scikit-learn->lightgbm) (0.14.1) Requirement already satisfied: pystan in /srv/conda/envs/notebook/lib/python3.7/site-packages (2.19.1.1) Requirement already satisfied: numpy>=1.7 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from pystan) (1.18.1) Requirement already satisfied: Cython!=0.25.1,>=0.22 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from pystan) (0.29.14) Collecting fbprophet Using cached https://files.pythonhosted.org/packages/33/fb/ad98d46773929079657706e6b2b6e366ba6c282bc2397d8f9b0ea8e5614c/fbprophet-0.5.tar.gz Requirement already satisfied: Cython>=0.22 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (0.29.14) Requirement already satisfied: pystan>=2.14 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (2.19.1.1) Requirement already satisfied: numpy>=1.10.0 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (1.18.1) Requirement already satisfied: pandas>=0.23.4 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (0.25.3) Requirement already satisfied: matplotlib>=2.0.0 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (3.1.2) Requirement already satisfied: lunardate>=0.1.5 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (0.2.0) Requirement already satisfied: convertdate>=2.1.2 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (2.2.0) Requirement already satisfied: holidays>=0.9.5 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (0.9.12) Requirement already satisfied: setuptools-git>=1.2 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from fbprophet) (1.2) Requirement already satisfied: pytz>=2017.2 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from pandas>=0.23.4->fbprophet) (2019.3) Requirement already satisfied: python-dateutil>=2.6.1 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from pandas>=0.23.4->fbprophet) (2.8.0) Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from matplotlib>=2.0.0->fbprophet) (2.4.6) Requirement already satisfied: cycler>=0.10 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from matplotlib>=2.0.0->fbprophet) (0.10.0) Requirement already satisfied: kiwisolver>=1.0.1 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from matplotlib>=2.0.0->fbprophet) (1.1.0) Requirement already satisfied: pymeeus<=1,>=0.3.6 in /srv/conda/envs/notebook/lib/python3.7/site-packages (from convertdate>=2.1.2->fbprophet) (0.3.6) Requirement already satisfied: six in /srv/conda/envs/notebook/lib/python3.7/site-packages (from holidays>=0.9.5->fbprophet) (1.12.0) Requirement already satisfied: setuptools in /srv/conda/envs/notebook/lib/python3.7/site-packages (from kiwisolver>=1.0.1->matplotlib>=2.0.0->fbprophet) (41.2.0) Building wheels for collected packages: fbprophet Building wheel for fbprophet (setup.py) ... \^C anceled ERROR: Operation cancelled by user
In [6]:
import lightgbm as lgb
import numpy as np
import pandas as pd

from fbprophet import Prophet
from matplotlib import pyplot as plt
from pmdarima import auto_arima
from sklearn.metrics import mean_absolute_error, mean_squared_error

myfavouritenumber = 13
seed = myfavouritenumber
np.random.seed(seed)
--------------------------------------------------------------------------- ModuleNotFoundError Traceback (most recent call last) <ipython-input-6-be3ff468ba06> in <module> 3 import pandas as pd 4 ----> 5 from fbprophet import Prophet 6 from matplotlib import pyplot as plt 7 from pmdarima import auto_arima ModuleNotFoundError: No module named 'fbprophet'
In [ ]:
jovian.commit()
[jovian] Saving notebook..
In [ ]: